Fandom

Mini-Wikia

Ruby 4 Everyone/Installation

< Ruby 4 Everyone

1.771Seiten in
diesem Wiki
Seite hinzufügen
Diskussion0 Teilen

Störung durch Adblocker erkannt!


Wikia ist eine gebührenfreie Seite, die sich durch Werbung finanziert. Benutzer, die Adblocker einsetzen, haben eine modifizierte Ansicht der Seite.

Wikia ist nicht verfügbar, wenn du weitere Modifikationen in dem Adblocker-Programm gemacht hast. Wenn du sie entfernst, dann wird die Seite ohne Probleme geladen.

Um mit Ruby beginnen zu können brauch man eigentlich nur den Ruby-Interpreter und einen Texteditor, vorzugsweise mit Syntax-Highlight (Farbige Hervorhebung des Codes zu Verbesserung der Übersichtlichkeit).

unter Windows

Unter Windows ist die Installation gewohnt einfach: Einfach den Installer von http://rubyforge.org/projects/rubyinstaller/ herunterladen, installieren, fertig!

unter MacOS X

Glückwunsch, du bist fertig! Unter MacOS X ist der Ruby-Interpreter bereits vorinstalliert.

unter Linux

Bei den meisten Linuxdistributionen ist Ruby bereits mitgeliefert. Klarheit schaft dieser Befehl:

$ ruby --version

Ist Ruby installiert, wird nun die Versionsnummer angezeigt. Falls das nicht der Fall ist, suche deine passende Distribution heraus und tippe den Code in die Shell.

Fedora Core

# yum install ruby ruby-devel

Debian & Ubuntu

# apt-get install ruby

Gentoo

# emerge ruby

Editoren

Die Editoren benötigt man zur Erstellung eigener Rubyprogramme. Eigentlich eigent sich hier jeder gewöhnliche Texteditor, wir empfehlen allerdings, einen Editor mit einer automatischen, farbigen Hervorhebung der Syntax (Grammatik)

Platformunabhängig

NetBeans IDE

Windows

Nodepad++

scintilla

Linux

KATE oder gedit

MacOS X

aquamacs

TextMate

textwrangler


Auch bei Fandom

Zufälliges Wiki